[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[efax-users] Can't send fax as USER

Hi all folks,

RH 8.0
KDE 3.0.3.-8.3

Faxing only works as ROOT but fails as USER

I can fax by using "Send a Fax" as ROOT only.  It works on CUPS and
LPRng as welll

Permission already allowed on "/dev/modem" and "ttyLT0" (symbolic link).
# ./ppxpadduser  performed.

kppp is not running.  I am using broadband to connect Internet and my
PC is permanently connected to broadband.  In very rare occasion I use

During faxing as USER a temporary text lock file is automatically
created to lock /dev/modem 

Log file: 
efax: 32:49 created text lock file /var/lock/LCK..modem 
efax: 32:49 opened /dev/modem 

(hanging here)

$ cd /var/lock/

$ ls -al
total 20
drwxrwxrwx    4 root     lock         4096 May 24 18:23 .
drwxr-xr-x   21 root     root         4096 May  5 01:51 ..
-r--r--r--    1 satimis  satimis        11 May 24 18:23 LCK..modem
drwxr-xr-x    2 root     root         4096 May 24 17:16 subsys
drwxr-xr-x    2 uucp     uucp         4096 Jul 20  2002 uucp

$ cat LCK..modem

I found following line in /etc/fax.rc

LOCK='-x /var/lock/LCK..$DEV'

I have tried to comment it still with the same result - /dev/modem 

I followed the steps as described in "efax enhenced" with the same
result /dev/modem locked


fax make AAA.ps
fax send AAA.ps.001

As ROOT no problem at all.

I have tried several days without a solution.  Kindly help.

Stephen Liu